Hiba: Hozzáférés a DEX feladat most lehetetlen, kezdve 1.4.0

szavazat
0

Most Cégem akar hozzáadni a Google Analytics a régi app. Azt követi a google develper doc, add lib az android stúdió, de a következő hibaüzenetet kapom mikor szeretne szinkronizálni Gradle:

Error:Access to the dex task is now impossible, starting with 1.4.0
1.4.0 introduces a new Transform API allowing manipulation of the .class files.
See more information: http://tools.android.com/tech-docs/new-build-system/transform-api

Az alkalmazásom Gradle változata van

classpath 'com.android.tools.build:gradle:1.2.3'

Találok megoldást, mint ez: adja meg a link leírása itt , de ez nem működik. Bárki, aki megoldást köszönhetően

Találom, ez fog történni, amikor hozzá a Google Analytics lib a projekt szintjén build.gradle függőségek .a classpath jelentése: classpath „com.google.gms: google-szolgáltatás: 1.5.0-beta2”, de én app régi és a Gradle jelentése: classpath „com.android.tools.build:gradle:1.2.3” .Ha szinkronizálni, akkor jelentse az error.when I módosítani classpath mint ez: classpath „com.android.tools.build : Gradle: 1.5.0' , ez is happend .Mi tehetek? köszönöm írja kép leírása itt

A kérdést 07/06/2016 03:48
a forrás felhasználó
Más nyelveken...                            


1 válasz

szavazat
0

Melyik a Logcat dob

Hozzáférés a DEX feladat most lehetetlen, kezdve 1.4.0

Classpath egy olyan paraméter, a Java Virtual Machine, vagy a Java fordító, amely meghatározza a helyét a felhasználó által definiált osztályok és csomagokat.

Nyílt projektek szintjén build.gradle és Call ezt

    dependencies {
    classpath 'com.android.tools.build:gradle:1.5.0' //or 2.0.0

      }

Ezután Clean-Rebuild-Syncaz IDE

Válaszolt 07/06/2016 04:21
a forrás felhasználó

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more