Nem lehet elindítani a meglévő konténer Podman

szavazat
0

Én futás Podman Ubuntu 18.04. Nem tudok kezdeni egy tartály megállítása után.

Futok a tartályt:

podman run -d -p 8081:8081 --name nexus -v /opt/nexus-data:/nexus-data sonatype/nexus3

És elindul ok. Ha futok:

podman container stop nexus
podman container start nexus

Kapok egy hiba: Hiba: nem tudja elindítani konténer „nexus”: tartály create sikerült (nincs naplókat conmon): EOF

Amikor fut hibakeresési naplózás látom ezt a kimenetet:

Debu [0000] Előkészítés esemény backend journald
Debu [0000] segítségével futási / usr / lib / CRI-o-Runc / sbin / Runc WARN [0000] Hiba inicializálása konfigurálva OCI futásidejű CFuttassa: nincs érvényes végrehajtható találtunk OCI futásidejű CFuttassa: érvénytelen argumentum .... Debu [0000] lecsatolható konténer 419f6576ff23328c6445526058c9988aa27a4b69605348230fa26246a522c726 ERRO [0000] nem tudja elindítani konténer nexus: tartály create sikerült (nincs naplókat conmon): EOF

A forrás kép: docker.io/sonatype/nexus3

Nem tudom, hogy mi a „érvénytelen argumentum” a naplók segítségével. Muszáj, hogy adja át egy másik érv?

A kérdést 14/01/2020 00:02
a forrás felhasználó
Más nyelveken...                            


2 válasz

szavazat
0

úgy tűnik, hogy a probléma a legújabb változata conmoncsomagot Project Atomic PPA (v 2.0.3).

Ugyanez volt a probléma, és telepítettem egy kisebb változata conmoncsomag (v 2.0.0) származó, https://launchpad.net/ubuntu/+archive/primary/+files/conmon_2.0.0-1_amd64.deb

Ez egy olyan csomag épített Eoan. Azonban dolgozott én Bionic környezet és képes vagyok kezdeni a konténerek újra.

Válaszolt 14/01/2020 09:36
a forrás felhasználó

szavazat
0

Amint @Loki Arya megjegyezte, hiba a közös csomag okozza a problémát. Mivel Podman az Unbuntu már nem kap otthont projectatomic ppa, a frissítések után verzió 1.6.2, amely rögzítette a hiba nem állt rendelkezésre.

Eltávolítása után a projekt atomi ppa és minden kapcsolódó csomagok, én reinstalled Podman az Ubuntut az új lerakat helyen van

Kipróbáltam Podman (1.7), és ez a munka nagy, beleértve a start parancs

Válaszolt 18/01/2020 19:22
a forrás felhasználó

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more