HAProxy / Docker: 502 Bad Gateway amikor üti Docker tartály futó Lombik / reagálnak app

szavazat
0

Próbálom Dockerize egy Lombik / reagálni webes alkalmazás megkönnyíti a fejlesztési / együttműködést, de gondjai egyre megfelelő választ a kérelmet. Vagyok képes, hogy a kép és a beépített Lombik szerver indult egy tartályban, de gondjai valójában üti meg.

Az általunk használt HAProxy hogy előre kéri, és a dolgok jól működik, amikor már a proxy és a webszervert futtató helyben. A kérdés már egyre dokkoló a keverékhez. Úgy vélem, meg kell egy port mapping kérdés, de nem vagyok az ötletek, és úgy érzem lehet a kulcs hiányzik HAProxy / Docker finomságok. A proxy.cfg fájl a következőképpen néz ki (az idegen hosts nem tartalmazza):

global
 maxconn 4096
 pidfile ~/tmp/haproxy.pid

defaults
 log global
 log 127.0.0.1 local0
 log 127.0.0.1 local1 notice
 mode http
 timeout connect 300000
 timeout client 300000
 timeout server 300000
 maxconn 2000
 option redispatch
 retries 3
 option httpclose
 option httplog
 option forwardfor
 option httpchk HEAD / HTTP/1.0


frontend dev
   bind *:8080 ssl crt ./proxy.pem

    acl allow_web path_beg /app/

    use_backend be_web if allow_web

backend be_web
 balance roundrobin
 server web_5000 localhost:5000

Dockerfile:

FROM node:10.6.0

RUN apt-get update
RUN apt-get install -y python-pip python-dev build-essential 

WORKDIR /usr/src/app

COPY ./package.json .
RUN npm install
COPY . .
RUN pip install -e ./server

CMD [npm, start]

dokkoló-compose.yml:

version: 3

services:
    userportal:
        build: .
        volumes:
            - /usr/src/app/node_modules
            - .:/usr/src/app
        ports:
            - 5000:5000

A Lombik szerver kötődik port 5000 így a leképezés. Megpróbáltam az esetben a tartály IP-címet localhost(például 172.19.0.2:5000), de az eredmény ugyanaz.

Megjegyzés HAProxy fut a saját terminál és nem a tároló belsejében.

A kérdést 13/02/2020 23:59
a forrás felhasználó
Más nyelveken...                            


1 válasz

szavazat
0

Tudnia kell, hogy a tartály IP előre

docker inspect -f '{{range .NetworkSettings.Networks}}{{.IPAddress}}{{end}}' container_name_or_id

Egy bizonyos ponton, ha szeretné használni HAProxy ez lesz könnyebb, hogy ez belülről dokkoló levélírás, hogy az avoir hálózati problémák

Ha nem akarsz, akkor megpróbálhatja: haproxy.conf

global
  maxconn 4096
  pidfile ~/tmp/haproxy.pid

defaults
  log global
  log 127.0.0.1 local0
  log 127.0.0.1 local1 notice
  mode http
  timeout connect 300000
  timeout client 300000
  timeout server 300000
  maxconn 2000
  option redispatch
  retries 3
  option httpclose
  option httplog
  option forwardfor
  option httpchk HEAD / HTTP/1.0


frontend dev
  bind 0.0.0.0:8080 ssl crt ./proxy.pem   // <-- change wildcard with 0.0.0.0
  acl allow_web path_beg /app/
  use_backend be_web if allow_web
  default_backend be_web                  // <-- add this line

backend be_web
  balance roundrobin
  mode http
  option forwardfor                       // <-- add this line
  option httpchk GET / HTTP/1.1           // <-- add this line
  server web_5000 userportal_1:5000 check // <-- change localhost to the nane of running container "userportal_1" or the IP if you get it

Dockerfile:

FROM node:10.6.0

RUN apt-get update
RUN apt-get install -y python-pip python-dev build-essential

WORKDIR /usr/src/app

COPY ./package.json .
RUN npm install
COPY . .
RUN pip install -e ./server

EXPOSE 5000 // <-- add this ine

CMD ["npm", "start"]

dokkoló-compose.yml

version: "3"

services:
  userportal:
    build: .
    volumes:
      - /usr/src/app/node_modules
      - .:/usr/src/app
    ports:
      - "5000:5000"

Megpróbáljuk a HAProxy a dokkoló-compose.yml sokat segít

Válaszolt 14/02/2020 00:56
a forrás felhasználó

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more