Nyomon követése: rails3 és korcs kérdés - rubin 1.9.2

szavazat
0

Ez egy nyomon követése kérdés a kérdésemre írt tegnap, amely úgy tűnik, hogy „lóg” a levegőben után kapok néhány válaszok emberek, hogy megpróbáltak segíteni.

Egyébként, az egyetlen különbség az idő és az előző próbálkozás, hogy én használ RVM telepíteni egy használatra Ruby 1.9.2. A korcs van 1.2.0.pre verzió óta korcs 1.1.5 nem telepíti a Ruby 1.9.2.

Saját Gemfile a következő:

source 'http://rubygems.org'
    gem 'rails', '3.0.8'
    gem 'pg'
    gem 'mongrel', '>= 1.2.0.pre2'
    gem cgi_multipart_eof_fix
    gem fastthread

És

A hiba napló az alábbi módon, amikor elindul „mongrel_rails klaszter :: start”:

 ** Daemonized, any open files are closed.  Look at tmp/pids/mongrel.3000.pid and
 log/mongrel.3000.log for info.
    ** Starting Mongrel listening at 127.0.0.1:3000
    ** Starting Rails with development environment...
    ** Mounting Rails at /home/ec2-user/test_ruby_1.9.2...
    /home/ec2-user/.rvm/gems/ruby-1.9.2-p180/gems/activesupport-3.0.8/lib/active_sup
port/dependencies.rb:239:in `require': no such file to load -- dispatcher (LoadE
rror)
        from /home/ec2-user/.rvm/gems/ruby-1.9.2-p180/gems/activesupport-3.0.8/l
ib/active_support/dependencies.rb:239:in `block in require'
        from /home/ec2-user/.rvm/gems/ruby-1.9.2-p180/gems/activesupport-3.0.8/l
ib/active_support/dependencies.rb:225:in `block in load_dependency'
        from /home/ec2-user/.rvm/gems/ruby-1.9.2-p180/gems/activesupport-3.0.8/l
ib/active_support/dependencies.rb:596:in `new_constants_in'
        from /home/ec2-user/.rvm/gems/ruby-1.9.2-p180/gems/activesupport-3.0.8/l
ib/active_support/dependencies.rb:225:in `load_dependency'
        from /home/ec2-user/.rvm/gems/ruby-1.9.2-p180/gems/activesupport-3.0.8/l
ib/active_support/dependencies.rb:239:in `require'
        from /home/ec2-user/.rvm/gems/ruby-1.9.2-p180/gems/mongrel-1.2.0.pre2/li
b/mongrel/rails.rb:148:in `rails'
        from /home/ec2-user/.rvm/gems/ruby-1.9.2-p180/gems/mongrel-1.2.0.pre2/bi
n/mongrel_rails:116:in `block (2 levels) in run'
        from /home/ec2-user/.rvm/gems/ruby-1.9.2-p180/gems/mongrel-1.2.0.pre2/li
b/mongrel/configurator.rb:149:in `call'
        from /home/ec2-user/.rvm/gems/ruby-1.9.2-p180/gems/mongrel-1.2.0.pre2/li
b/mongrel/configurator.rb:149:in `listener'
        from /home/ec2-user/.rvm/gems/ruby-1.9.2-p180/gems/mongrel-1.2.0.pre2/bi
n/mongrel_rails:102:in `block in run'
        from /home/ec2-user/.rvm/gems/ruby-1.9.2-p180/gems/mongrel-1.2.0.pre2/li
b/mongrel/configurator.rb:50:in `call'
        from /home/ec2-user/.rvm/gems/ruby-1.9.2-p180/gems/mongrel-1.2.0.pre2/li
b/mongrel/configurator.rb:50:in `initialize'
        from /home/ec2-user/.rvm/gems/ruby-1.9.2-p180/gems/mongrel-1.2.0.pre2/bi
n/mongrel_rails:86:in `new'
        from /home/ec2-user/.rvm/gems/ruby-1.9.2-p180/gems/mongrel-1.2.0.pre2/bi
n/mongrel_rails:86:in `run'
        from /home/ec2-user/.rvm/gems/ruby-1.9.2-p180/gems/mongrel-1.2.0.pre2/li
b/mongrel/command.rb:210:in `run'
        from /home/ec2-user/.rvm/gems/ruby-1.9.2-p180/gems/mongrel-1.2.0.pre2/bi
n/mongrel_rails:282:in `<top (required)>'
        from /home/ec2-user/.rvm/gems/ruby-1.9.2-p180/bin/mongrel_rails:19:in `l
oad'
        from /home/ec2-user/.rvm/gems/ruby-1.9.2-p180/bin/mongrel_rails:19:in `<
main>'

Kérem, segítsen. TIA.

A kérdést 12/06/2011 13:37
a forrás felhasználó
Más nyelveken...                            


1 válasz

szavazat
1

Addding gem „diszpécser” a Gemfile tűnik, hogy segítsen Ha diszpécser gem nem része a listán, akkor erre gem install diszpécser Végül tegye köteg frissítés vagy csomagban telepíteni Köszönöm.

Válaszolt 13/06/2011 01:50
a forrás felhasználó

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more